Если я сменю ядро , будут ли работать плагины?

Я хочу сменить ядро с Genisys на LiteCore , версия 1.1.5 ( 3.0.0 )
Будут ли работать плагины?

Если плагины так захотят, то да

1 лайк

Скорее всего нет, так они сделаны на генку

Лайт это Улучшенная генка, так что да

Всм 3.0.0 на Генке Я думал там всегда 2.0.0 базового апи

2.0.0 это улучшенный 3.0.0
Тоесть допустим в 2.0.0 нету функции получения пинга, а в 3.0.0 оно есть, так что по сути 2.0.0 это тот же 3.0.0 только улучшенный

Все ошибаются в комментариях. Вот почему.
Большинство плагинов было сделано для GenisysPro, например, такие как FactionsPro, PvPBar и куча других. Так вот сами попробуйте эти плагины на LiteCore запустить. У вас сто процентов тот же самый FactionsPro крашнется. Ну а если он никакой ошибки не выдал, то попробуйте зайти в игру и ввести что-то типа /f create или /clan create.
Результат будет нулёвым и сервер скажет: Произошла неизветная ошибка при выпонении команды.

Не путайте LiteCore и GenisysPro - да, лайт форк генки, но кодом они немножечко отличаются. Только каким-то образом это "немножечко" влияет на работу большинства плагинов. Не хотелось бы без системы кланом остаться на сервере, правда? Или в лучшем случае, переходите на PMMP4, там работает всё без проблем и онлайн наплывёт большой...

1 лайк

Кинька генку мне, я разрушу этот миф