Какие могут быть проблемы с реализацией мультипротокола на базе 1.1.5?

Данная тема создана не для обзывательств, а для филосовской беседы, чтобы понять, что я и другие делают не так и почему большинство плагинов на мультипротокол — такое надувательство.

Для примера тут эта штука:

данная тема создана для унижения тех, кто по причине ретроградства все еще играет в 1.1.5

1 лайк

любые

1 лайк

в частности - инвентари, чанки

2 лайка

Потому что большинство этих плагинов просто подменяют версию протокола у клиента при входе и довольны. Однако этого, внезапно, недостаточно.

Сервер просто будет думать что у клиента такой-же протокол и пропустит его дальше. Но клиент то продолжит посылать пакеты, как хочет он, а сервер обрабатывать их и отвечать, как хочет он. Это тебе ещё повезло если игрок заспавнился, зачастую с таким подходом он просто не зайдет на сервер (и вероятно словит креш). Изменился пакет отправки чанков - хоть обосрись, клиент не отрисует чанки из пакета протокола новее, потому что он не поймет что от него просят. И таких приколов тысячи, и чем выше ренж поддерживаемых протоколов, тем сложнее разработка мультиверсии, соответственно выше цена. Так-что если ты думаешь, что 1.1-1.19 за 50к это шуточки-приколы, то увы, нет и тебе ещё повезло с ценой

2 лайка

1.1 - 1.19 ему мало кто продаст за 50к, если не забывать об адекватности кода, хорошей структуре и учесть многие ньюансы, получится 70-100. а ваще щас очень мало людей, которые готовы такое сделать

2 лайка

в одной из предыдущих тем я говорил про лайткор мв 1.1 + 1.19, за 15к. я никогда не делал такое, поэтому цена 15к. о нормальном коде и реализации забудьте, не за 15к.

2 лайка

Ты очень чётко и детально описал мой случай.

Как я понял, проще свой клиент на нужную версию забабахать (в дополнение к слитым, которых лично я уже 2 в коллекции держу), чем реализовывать мультиверсию.

ты можешь реализовать мультиверсию, без проблем. только тебе нужны большие знания)

2 лайка

Английский язык я знаю, но челику с Гитхаба бы научиться поподробнее мысль излагать.

1 лайк

Я просто видел работу мультиверсии на Гринвиксе и могу сказать, что работает она там крайне криво, вызывая невидимых и неуязвимых для удара npc и игроков, а также баги с чанками, о которых сказано выше. И чем дальше в лес, тем больше багов!

1 лайк

При всём моём неуважении к мату, тут я полностью согласен.

есть реально крутые мв кодеры, я знаю парочку таких, один продает свою старую мв с ванильными фичами и мультипоточностью за 30к, поверь, я чекал разные его видео, которые он мне кидал, она того стоит

2 лайка

Полный анализ жадности и рукожопства создателя Гринвикса

могу тебе скинуть ролики в тг

1 лайк

Про что?

про мв эту

2 лайка