Помогите 1.1.5 лайткор

Помогите непонятко с плагинам код крашет
plugin.yml (81 Байт)

1 лайк

Код

<?php

namespace laffykz;

use pocketmine\plugin\PluginBase;
use pocketmine\event\Listener;
use pocketmine\event\player\PlayerLoginEvent;

class laffy extends PluginBase implements Listener{
public function onEnable(): void{
$this->getServer()->getPluginManager()->registerEvents($this, $this);
}

public function onLoginOnPc(PlayerLoginEvent $source){
$player = $source->getPlayer();
if($player->getDeviceOS() == 7){
$player->close("","§l§aПк мен оинауға болмаиды!"):
}
}
}

Ойбай, пк трогают

Ок.
PlayerPreLoginEvent

use pocketmine\event\player\PlayerPreLoginEvent;
1 лайк

Ок.

А что не так

Зайди в PluginBase и чекни функцию onEnable()

Чекнул, она не абстрактная

Эта тема была автоматически закрыта через 12 часов после последнего ответа. В ней больше нельзя отвечать.