Помогите пожалуйста пацаныы

Could not load plugin ‘/home/plugins/DevTools.phar’: Invalid plugin manifest: Invalid Plugin “permissions”: Nested permission declarations are no longer supported. Declare each permission separately.

ядро какое?

PMMP 4.2.0 1.18.10 Вот

последний DevTools нужно собирать с помощью composer

Всм

дома буду, соберу

1 лайк

Окей, спасибо буду ждать)

ну видимо DevTools устарел, если ядро уже не поддерживает манифесты где есть вложенные разрешения. если ядро обновилось, то и DevTools наверняка

Ааа я нашел рабочил дев тулс, вот проблема с плугом Could not load plugin ‘/home/plugins/Admin’: Invalid plugin manifest: Command admin does not have a valid permission set

ну тут уже разбирайся с plugin.yml. ошибка говорит, что для команды “admin” не указано разрешение

если это вообще твой плагин

'это не мой плуг, кста а как вообще можно перевести плагин с апи 3.0.0 на 4.0.0

переписать (внезапно)

с версией 4.х.х много чего изменилось, и просто изменить версию апи в манифесте не получится

старые плагины с пм3 не будут работать как ты их не пихай, разве что некоторые примитивные может смогут

Понял, придется собирать сборку спасибо за помощь!

А есть мультиядро 1.18 - 1.19?

или еще какие нибудь

ну, почти со всеми. тот же форм апи работает просто изменив апи:)

Эта тема была автоматически закрыта через 12 часов после последнего ответа. В ней больше нельзя отвечать.