[PMMP5] Проблема с плагином

Плагин не нашел класс, но плагин Libasynql есть, вирион тоже.

Ошибка:
Screenshot_2022-07-29-10-32-45-44

Код:

Импорты:

Какой плагин. Это вирион.
Он должен лежать в папке virions

он там и лежит

Скинь его


libasynql-6493eb892a367cdbbcaad7d336284294683f84d3.zip (80.3 КБ)

Капец…

м?

Ты неправильно установил

А ещё api 4, а не 5
Screenshot_20220729_133121_bin.mt.plus

Как правильно установить?

ок

Пм5 ещё не поддерживается

Это я понял скачаю новую версию, но ты мне сказал что я его неправильно установил, где именно?

Пути должны выглядеть как плагин в папке

libasynql -> src -> poggit -> и тд
              |
              V
          virion.yml
public function getHome($player){
    	$username = $player instanceof Player ? strtolower($player->getName()) : strtolower($player); 
        $home = $this->homes->query("SELECT COUNT(*) as count FROM `home` WHERE `username` = '". $username." '");
        while($result = $home->fetchArray(SQLITE3_ASSOC)){
        	$count = $result['count'];
        }
        return $count;
    }

Почему это игнорируется?

Вирион поддерживает апи 4.0.0-4.6.1(4.6.1 сейчас последний, тобишь версия 1.19.10)

Потому что ты пишешь не в своей теме